Jump to content
Nokioteca Forum

Procedura Installazione Android 2.2-2.3 (Manual-Guide)


tigernero79
 Share

Recommended Posts

scusa ma scrivi bene le maiuscole? Perchè io il file lo vedo online e il link funziona.

@denni: il market è a posto ora?

Appena riprovato.

Connessione a ubuntuone.com|91.189.89.205:80...connesso
HTTP richiesta inviata, aspetto la risposta... 404 Not Found

edit: tentato da pc... NOT FOUND... a sto punto posso solo essere io il rimba che non riesce...

edit2:Ho provato a scrivere http://ubuntuone.com/p/n0X (enne zero ics) e vien giù un mp3 da 14 mega... LOL!

Edited by akira1980
Link to comment
Share on other sites

nada non vuole andare. lo script adesso è ok. però l'unica cosa che quando mi arriva all'install del kernel mi dice che ha avuto problemi con il pacchetto. poco male mi son detto, tanto ce lo avevo già. lancio Nitdroid e mi fa tutta la procedura di partenza poi, dopo la scritta ANDROID mi inizia a dare errori e si riavvia alla schermata di scelta del multiboot... boh! Non c'è una procedura di "pulizia" per toglierlo sia dalla /home che da SD per riprovare tutto da capo?

Link to comment
Share on other sites

non credo sia riconducibile allo script questo problema, lo script semplicemente automatizza la procedura, e ameno che non abbia commesso errori di scrittura non dovrebbe dare problemi..

magari prova a usarlo su un installazione pulita di maemo, credo sia meglio.

Link to comment
Share on other sites

Ok sono arrivate le prime prove e le conferme che la mia idea era buona e che sembra funzionare come da aspettative.

Vantaggi:

  • Viene fatto tutto da Nitdroid Installer senza quasi nulla da fare a mano
  • Viene installato direttamente Gingerbread 2.3.3 N11 senza eseguire passaggi evitabili ed assolutamente inutili quali mettere la 0.0.8, sostituirla (a mano) con la 0.0.9 per poi sostituirla ancora (a mano) con la 2.3.3
  • Vengono installati anche i fix usciti post pacchetto N11

Svantaggi:

  • Senza ulteriori e più pesanti modifiche, cmq possibili, la procedura va bene solo per chi vuole installare sulla MicroSD, per chi vuole invece installare sulla eMMC interna serve ancora una installazione manuale o lo script di Fez V.
  • Attualmente la soluzione in prova richiede un minimo lavoro manuale (creare un file e modificarne un altro), ma volendo si potrebbe rilasciare un nuovo pacchetto nitroid installer (0.2.8) con già le modifiche incorporate in modo che diventi ZERO il lavoro da fare

Aspetto ulteriori prove e conferme (o anche smentite alias segnalazioni di problemi) e poi se davvero funziona bene posto la soluzione anche qua.

Ecco la guida citata:

  1. Installare nitdroid-installer_0.2.7_armel.deb (non quello dei repository che è la 0.2.6)
    Se usate il comando dpkg -i per installare e non avevate una versione precedente (es. 0.2.6) già installata allora dovrete gestire a mano tutte le dipendenze necessarie (multiboot, rootsh, ...ecc).
    Una scorciatoia possibile è quella di installare prima la 0.2.6 dai repository con apt-get e poi aggiornare alla 0.2.7 con dpkg -i
  2. Creare nella cartella /home/user/MyDocs/ un file di testo di nome "nitdroid.manifest" in cui scrivere:
    #
    # Manifest file for NITDroid
    #
    
    # Root filesystem tar balls
    rootfs		http://downloads.nitdroid.com/e-yes/N11_Vostok.tar.bz2		5dc990b8c4a79f4b0c348da53ae4849b
    rootfs		http://downloads.nitdroid.com/e-yes/N11_market_fix.tar.bz2	3ab71a59fe9452f3ddc16f63750c659d
    rootfs		http://downloads.nitdroid.com/e-yes/ofono047_oril008.tar.bz2	c1c2d605c46b7544cd286c41b8cd9e8b
    
    # Deb packages
    package		http://downloads.nitdroid.com/e-yes/nitdroid-kernel-2.6.28-06_final1_armel.deb	23764ad91ff5c2094cf1ef70f40d3330
    
    # End.


  3. Aprire una finestra terminale e lanciare l'installer digitando nitdroid file:///home/user/MyDocs/nitdroid.manifest
  4. Alla richiesta di procedere con l'installazione digitare YES (in MAIUSCOLO)

Questa è una seconda versione con una modifica suggerita da e-yes stesso, che non è ancora stata provata da nessuno (che io sappia) ma che dovrebbe essere corretta.

Provatela e se funziona, valutate se integrarla nella guida in prima pagina

EDIT 22 Apr ore 14.00 :

Corretto errore al punto 3.

Ora c'è qualcuno che l'ha provato e sembra funzionare

Edited by FabryN
Link to comment
Share on other sites

Ecco la guida citata:

  1. Installare nitdroid-installer_0.2.7_armel.deb (non quello dei repository che è la 0.2.6)
  2. Creare nella cartella /home/user/MyDocs/ un file di testo di nome "nitdroid.manifest" in cui scrivere:
    #
    # Manifest file for NITDroid
    #
    
    # Root filesystem tar balls
    rootfs		http://downloads.nitdroid.com/e-yes/N11_Vostok.tar.bz2		5dc990b8c4a79f4b0c348da53ae4849b
    rootfs		http://downloads.nitdroid.com/e-yes/N11_market_fix.tar.bz2	3ab71a59fe9452f3ddc16f63750c659d
    rootfs		http://downloads.nitdroid.com/e-yes/ofono047_oril008.tar.bz2	c1c2d605c46b7544cd286c41b8cd9e8b
    
    # Deb packages
    package		http://downloads.nitdroid.com/e-yes/nitdroid-kernel-2.6.28-06_final1_armel.deb	23764ad91ff5c2094cf1ef70f40d3330
    
    # End.


  3. Aprire una finestra terminale e lanciare l'installer digitando nitdroid MANIFEST_FILE=/home/user/MyDocs/nitdroid.manifest
  4. Alla richiesta di procedere con l'installazione digitare YES (in MAIUSCOLO)

Questa è una seconda versione con una modifica suggerita da e-yes stesso, che non è ancora stata provata da nessuno (che io sappia) ma che dovrebbe essere corretta.

Provatela e se funziona, valutate se integrarla nella guida in prima pagina

Questa è una seconda versione con una modifica suggerita da e-yes stesso, che non è ancora stata provata da nessuno (che io sappia) ma che dovrebbe essere corretta.

Provatela e se funziona, valutate se integrarla nella guida in prima pagina

FrabyN, valida o non valida è da testare giustamente

tale guida secondo il tuo modo funziona,

e parli di modificare il file manifest etc etc

ma la posti oggi 21/04, dopo test fatti e richieste tue su TMO,

purtroppo quando da me postato in data 13/04, l'unico modo SICURO

per installare la release 2.3.3 da n900 pulito,

era tramite nitdroid installer che da se lanciando il comando nitdroid,

installava la 0.0.8, successivamente upgrade alla 0.0.9 e installazione della 2.3.3 finale.

quindi puoi ora illustrare tutto ciò che vuoi,

sta di fatto che in data 13 c'era bisogno della 0.0.9,

e che chiunque lavorasse perchè questo fosse diverso in tal data nn era possibile.

ragion per cui

apprezzo il tuo interessamento alla risoluzione di tale problema che oggi spieghi ma che nn trovano riscontro alle accuse inutili fatte gg fa.

see you

messaggio di avviso uscita android 2.3.3 post n°203

Inviato 13 aprile 2011 - 22:48

Uscito android 2.3.3 stabile per il nostro mattoncino, richiede la presenza della release 0.0.9 o gingerbread installata...

sono stanco per postarla ora e dovrei comunque testarla sul mio prima.

metterò l'update sabato nel primo post di questa discussione

see you

changelog:

- Android Gingerbread 2.3.3 (stabile)

- Ultima versione di Google Maps

- Archiviazione di massa USB funziona

- Sensore di accelerazione nella nuova modalità "aggressiva"

- Icona che mostra la potenza del segnale WLAN

- Problemi con lettore video e YouTube sono stati risolti

- Ofono nuovo nella versione 0.45 e dovrebbe funzionare stabile

- Electro Beam aggiunto effetto

- Suonerie, ecc aggiunto CyanogenMod

- Emergency Reboot (freccia blu + Shift + R + B )

Problema noto:

- Market non funziona

Messaggio modificato da tigernero79 il 13 aprile 2011 - 22:52

Edited by tigernero79
Link to comment
Share on other sites

valida o non valida è da testare giustamente

tale guida secondo il tuo modo funziona,

e parli di modificare il file manifest etc etc

Si è da testare, ma preciso che l'unica cosa da testare è se è scritto giusto il parametro da riga di comando (modifica che ha suggerito e-yes e che risulta più semplice, e devo dire più CORRETTA, della mia soluzione iniziale).

Il manifest alternativo ed il funzionamento tramite cambio del manifest è già stato provato e funziona (alias installa correttamente tutto ed alla fine hai una gingerbread N11 installata)

ma la posti oggi 21/04, dopo test fatti e richieste tue su TMO,

purtroppo quando da me postato in data 13/04, l'unico modo SICURO

per installare la release 2.3.3 da n900 pulito,

era tramite nitdroid installer che da se lanciando il comando nitdroid,

installava la 0.0.8, successivamente upgrade alla 0.0.9 e installazione della 2.3.3 finale.

quindi puoi ora illustrare tutto ciò che vuoi,

sta di fatto che in data 13 c'era bisogno della 0.0.9,

e che chiunque lavorasse perchè questo fosse diverso in tal data nn era possibile.

Non è proprio vero che era l'unico modo SICURO.

Sia perché c'erano molti altri modi di installare Nitdroid (io ed altri ad esempio l'abbiamo fatto senza mai usare Nitdroid-installer, ed abbiamo raggiunto lo scopo senza installare per forza altre versioni o fare chissà che) sia perché su TMO, per esempio, c'erano già altre guide che spiegavano (prima di Aprile) altri modi per installare senza passare dai passaggi da te citati , quindi le informazioni (all'estero) erano note a qualcuno almeno.

Diciamo che era una soluzione possibile, ma non era ne l'unica ne la più sicura ne una delle migliori (visto i passaggi evitabili che faceva).

Era però una soluzione che raggiungeva lo scopo.

Se tu (straniero non conoscitore dell'Italia) mi chiedi come andare da Milano a Torino, io magari in buona fede ti posso dire "Devi prendere il treno per Roma, poi a Roma prendere l'aereo per Cagliari ed infine a Cagliari prendere l'aereo per Torino".

Tu non sapendo nulla segui le mie istruzioni, che cmq alla fine ti portano dove vuoi, magari solo un po' dopo ma cmq arrivi dove vuoi arrivare.

Poi fra 2 mesi incontri qualcun altro che ti dice "ma no, c'è una via più semplice. C'è una strada/treno/aereo diretto tra Milano e Torino"

Questo non significa che ad oggi l'unica via è passare da Roma e solo fra 2 mesi sarà valida la strada diretta, significa solo che per mancanza di informazioni migliori oggi ti tocca passare da Roma, ma magari se oggi tu cercassi meglio forse lo scopriresti subito che non è per forza necessario deviare su Roma/Cagliari come erroneamente (ma ripeto in buona fede) ti hanno detto

PS

Puoi dire che al più c'era bisogno della 0.0.8 (dato che se non modifichi il manifest viene giù quella) ma della 0.0.9 NON c'è mai stato bisogno.

Certo la tua affermazione errata deriva da quanto letto in giro, quindi non ti si crocifigge certo per quello, ma rimane il fatto che la 0.0.9 non è mai servita.

ragion per cui

apprezzo il tuo interessamento alla risoluzione di tale problema che oggi spieghi ma che nn trovano riscontro alle accuse inutili fatte gg fa.

see you

Ciao

Edited by FabryN
Link to comment
Share on other sites

e che ne so guarda la data della guida su maemo talk :Dito:

Io posso solo dire che il 14 Aprile la guida era già così, ma cmq non ha molto importanza la data.

Nitdroid si installa sempre allo stesso modo (nomi dei files da scaricare a parte) da almeno dalla 0.0.8 in avanti, probabilmente era lo stesso anche con le versioni precedenti ma stiamo sul sicuro limitiamoci dalla 0.0.8 in poi

Il procedimento nelle sue 2 varianti per MicroSD e per eMMC finora è sempre stato lo stesso e si applica indistintamente alle 0.0.8 (2.2), 0.0.9 (2.2.2 mi pare), 2.3.0 e 2.3.3

Tutte funzionano indipendentemente dalla versione precedente (ho escluso dall'elenco la 2.3.1 perché non ho verificato se è un update da applicare sopra alla 2.3.0 o un pacchetto completo come la 2.3.3) e tutte si possono installare sia in eMMC (0.0.8 compresa) che in MicroSD

Edited by FabryN
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Questo sito utilizza i cookie per analisi, contenuti personalizzati e pubblicità. Continuando la navigazione, accetti l'utilizzo dei cookie da parte nostra | Privacy Policy