Jump to content
Nokioteca Forum
Sign in to follow this  
Il.Socio

Hack Per Tutti I Modelli - Flash Del Firmware Con Phoenix (Aggiunta Di Rp+)

Recommended Posts

Volevo chiedere cortesemente agli amici se l'operazione di aggiornamento firmware con phoenix deve avvenire con cellulare spento o acceso.

Grazie a chi vorrà rispondere.

Saluti a tutti.

Share this post


Link to post
Share on other sites

Salve a tutti,

innanzitutto ringrazio l'autore della guida, che mi ha dato la possibilità di fare l'hach al mio 5800 !!!

Tuttavia l'operazione è stata piuttosto travagliata, e ho riscontrato alcuni dei problemi citati nella discussione, per cui posto alcuni suggerimenti che possono tornare utili a chi ancora non fosse riuscito:

Sistema Operativo utilizzato per l'hack: Windows 7

1. CARTELLE in cui mettere i files del FW: le cartelle sono quelle indicate nel video! Inoltre, non ho dovuto modificare le impostazione di Phoenix, dato che di default ha impostate quelle cartelle.

2. PROBLEMA: errore "neither dp1.0 nor dp2.0 was found for the product or the product cannot be identified"

--Mia Soluzione:

a telefono acceso e collegato, avviare Phoenix e fargli identificare il modello del cell, poi spegnere il cell e procedere; in seguito Phoenix chiederà di scollegarlo, togliere la batteria, etc)

3. PROBLEMA: una volta spento, tolta batteria, collegato, attaccata batteria, acceso, da errore "The flashing failed. Do you want to retry the flashing?"

OUTIPUT ERRORE:

HRESULT 0x8401f141 (-2080247487)

Flash: Boot rom was not detected after phone boot up. Unable to start flashing.

--Soluzione:

bisogna premere il tasto di accensione in modo deciso, come per accendere, alrimenti il telefono non si "accende" correttamente: la controprova di una giusta pressione è che lo schermo di accende (tutto bianco)

4. PROBLEMA: il processo arriva a conclusione, ma esce l'errore "Flashing finalization failed. Do you like to retry the finalizing?" e il messaggio che la procedura è fallita come da output seguente:

OUTPUT ERRORE:

HRESULT 0x84210029 (-2078212055)

Firmware: Firmware update finalizing failed. Error 0x840E0808 - Framework: No valid variant packing list was available. Verify that such a file exists and that all fields follow specifications.

--Soluzione:

in realtà l'update ha funzionato: il cell aveva una schermata fissa, ho staccato la batteria e l'ho rimessa, ho riavviato, e il cell ha chiesto data, ora, paese, etc e aveva il nuovo FW modificato

Dopodiché ho installato RP+ lite e fatto le 2 patch, installato x-plore e ho potuto navigare il disco C.

PS: vi dico due cose utili per x-plore: dal menù dovete entrare in "impostazioni" ed attivarte la visualizzazione dei files di sistema e nascosti! Inoltre, per copiare un file da un posto all'altro dovete selezionarlo, cliccare l'icona in basso con i due foglietti vicini (che "marca" il file da copiare) e poi andare nella cartella di destinazione e da menù selezionare "select". COsì farà al copia.

Felice hack a tutti! :lol:

ALessio

Share this post


Link to post
Share on other sites

Credo tu stia usando una versione di Phoenix che hai reperito altrove.

Disinstallala... scarica ed installa la versione che trovi in questa guida e non dovresti avere nessun problema.

amico sono riuscito a fare tutto il procedimento, solo k ho perso tutti i numeri de la rubrica potresti dirme se posso recuperarli... grazie

Share this post


Link to post
Share on other sites

Il path in Phoenix è c:\documents and settings\all users\dati applicazioni\nokia\packages (o qualcosa di simile, non sono al mio PC ora e vado a memoria)

Comunque, ho navigato fino alla cartella nokia, mancava la packages che ho creato io ed al suo interno ho creato la sottocartella RM-588

Ho quindi copiato il mio UDA modificato e tutti gli altri dati scaricati con navifirm lì dentro, non va.

Siccome questo passaggio non è chiarissimo sulla guida, ho provato anche a rinominare la cartella RM-588 in RM588 e in RM588_50.0.001_000_000_U001, tanto per non cadere in qualche errore banale di interpretazione della guida, senza successo.

Ho provato cancellando tutto e scaricando direttamente con navifirm in quella cartella, e a modificare l'uda lì dentro, nulla

Infine, ho pure provato a scaricare direttamente dentro senza patchare l'uda, ancora non me lo vede

Come ultima risorsa, da una ricerca su google avevo trovato che per risolvere bisognava cambiare le Product Locations in Phoenix, ed ho prvato ad assegnare il percorso alla mia cartella anche da lì. Purtroppo è un errore su cui neanche BigG sembra sapere molto, almeno non finchè non faccio un corso di russo o di arabo... :( Nulla (anche se ho un dubbio in questo. Ho cambiato solo la USER, mentre la ADMINISTRATOR è rimasta quella di default... mumble, stasera ci provo...)

Intanto ringrazio per aver reso disponibile l'uda per il mio cell, immagino che altri apprezzeranno :) Stasera riprovo con calma e un po' meno sonno addosso e vediamo dove sto sbagliando (di sicuro è qualche cavolata che ho dimenticato, quanto mi seccano ste cose!!!! <_<

Anche io ho avuto questo stesso problema, praticamente ho creato la cartella esattamente nel percorso indicato da Phoenix (proprio come il tuo) e mi dava il tuo stesso errore. Solo che mi era venuto un sospetto quando mi ero accorto che il percorso da seguire era in una cartella nascosta del sistema. Allora ho seguito attentamente il video e alla fine mi sono accorto che la cartella da creare col nome RM-356 era in C:\Programmi\Nokia\Phoenix\Products

:rolleyes::doh:

Share this post


Link to post
Share on other sites

Volevo porre agli amici una domanda.

Il mio Nokia C5-03 product code 059C504 Tipo RM-697 presenta una versione del fw v. 20.0.024.

Per hackarlo posso usare cmq la uda della 1 pagina?

Grazie a chi mi vorrà aiutare.

Ciao a tutti.

Share this post


Link to post
Share on other sites

Ringrazio intanto della risposta.

Ho utilizzato uda di inizio thread.

Forse avrò avuto fortuna o forse non ho hackato, fatto stà che ho installato lite di rp+.

Certo alcune applicazioni mi dicono scadute.

No beep ok.

Boh.......non saprei.

Grazie cmq per le risposte e gli aiuti.

Ciao a tutti.

Share this post


Link to post
Share on other sites

ciao anche io ho un problema: installando phoenix del tuo link mi compare, dopo un casino di tempo questa finestra:

http://imageshack.us/photo/my-images/32/phoenixo.png/

sul desktop c'è il collegamento al programma ma aprendolo compare una finestra con su scritto: "install a nokia dongle and try to start application again"

come posso fare?

grazie in anticipo dell'aiuto

Edited by Kain105

Share this post


Link to post
Share on other sites

Raga ho un nokia 6120c fw 6.01 dopo aver seguito questa guida ho hackato il mio cell ho istallato anche romPatcher ma ora non so + quello che devo fare!! sareste così gentili da dirmi le voci passo passo ke devo fare anche per modificare la rom e cambiare la scritta nokia???

Share this post


Link to post
Share on other sites

ho un problema, quando provo ad installare delle patch mi dice errore nel certificato, contattare il fornitore. dov'è il problema?

Edited by ottodisc

Share this post


Link to post
Share on other sites

Ciao Il.Socio!!! :thumbsup_still: :thumbsup_still: Ritengo molto utile la tua guida in quanto sono riuscito ad hackare il mio nokia 6120c fw 6.01!!! ^_^ ^_^ Sono riuscito ad istalare romPatcher lite version, ma ora che devo fare??? :huh: ho accesso alle cartelle sys ma come faccio a modificare la rom e installare applicazioni unsigned??? :)

Edited by Il.Socio
Non quotare le guide!!!!

Share this post


Link to post
Share on other sites

ci sono riuscito... solo k ho perso tutti i numeri de la rubrica del telefono qualcuno potrebbe dirme come faccio per recuperli (è molto importante).. grazie

beh, mi disp ma dovevi farti un backup, i numeri non si possono recuperare :sad: :sad: :sad: mi dispiace tanto!!! :( :(

Share this post


Link to post
Share on other sites

ciao anche io ho un problema: installando phoenix del tuo link mi compare, dopo un casino di tempo questa finestra:

http://imageshack.us/photo/my-images/32/phoenixo.png/

sul desktop c'è il collegamento al programma ma aprendolo compare una finestra con su scritto: "install a nokia dongle and try to start application again"

come posso fare?

grazie in anticipo dell'aiuto

Probabilmente il tuo antivirus ha bloccato il cr*ck, e di conseguenza il programma ti da errore, prova a reistallare il programma DISATTIVANDO l'antivirus

Share this post


Link to post
Share on other sites

Alla fine sono riuscito a utilizzare Phoenix... ho copiato la cartella \RM-588 ovunque ho pensato potesse essere utile...e così ho flashato il cell... ora devo solo vedere se mi fa installare tutto... Unica nota... il cell mi sembra un po più lento ma... devo verificare :)

Share this post


Link to post
Share on other sites

Mi appare un errore non appena premo i tre puntini "..." su phoenix per selezionare il product code... mi dice: "Neither DP1.0 nor DP2.0 was found for the Product, or the Product cannot be identified." ho provato ad rifare tutto da capo per 2 volte ma mi da sempre il solito errore, cosa devo fare?? ..... grazie in anticipo :rolleyes:

Share this post


Link to post
Share on other sites

La guida e' da modificare...

per il momento, dovresti provare piazzando la cartella RM-xxx in uno di questi percorsi:

c:\ProgramData\Nokia\Packages\RM-xxx\

c:\Documents and Settings\All Users\Dati Applicazioni\Nokia\Packages\RM-xxx\

c:\Documents and Settings\All Users\Dati Applicazioni\Nokia\Packages\Products\RM-xxx\

c:\Program Files\Nokia\Phoenix\Products\RM-xxx\

c:\Program Files (x86)\Nokia\Phoenix\Products\RM-xxx\

Se vuoi essere proprio sicuro... mettine una copia in tutti i percorsi indicati.

Edited by Il.Socio

Share this post


Link to post
Share on other sites

scusate, ma quando flashio phoenix mi chiede di scollegare usb, togliere batteria ricollegare ed accendere.In cosa sbaglio?

io ho un n97 mini

ps l'uda che scarico dalla prima pagina va decompresso o messo nella cartella cosi come e'

Edited by n97piccolo

Share this post


Link to post
Share on other sites

lo devi decomprimere

Share this post


Link to post
Share on other sites

lo devi decomprimere

ok grazie

per il problema della richiesta di scollegarlo, togliere la batteria rimetterla, collegarlo ed accenderlo per fleshare?

forse mi manca qualche driver(uso seven)

Share this post


Link to post
Share on other sites

Anche uso seven e ho qualche problema: in particolare non riesco a fare il "Dead phone usb flashing" e cioè al momento dell'avvio del telefono, seguendo la procedura di phoenix, si avvia normalmente e non entra in modalità flashing...

Per cercare di superare il problema, ho provato e sono riuscito a flasharlo per ben due volte con la modalità normale (senza phone usb flashing) e il flashing è andato a buon fine, tuttavia installando rp+ lite e provando a fare l'hack mi dice *.ldd not found!! ...e la cosa mi pare stranissima in quanto il flashing è andato a buon fine per ben due volte con il file uda modificato (per esere certi ho controllato con nokiacoker se erano presenti i file ldd e ci sono!) e quindi la cosa mi pare davvero strana... forse facendo il flashing con la modalità normale il telefono si accorge di questi file ldd "superflui" e li cancella? non so che pensare.

tuttavia non riesco proprio a fargli eseguire il flashing in dead mode...

edit: è un N95 RM-159

Edited by tigreale

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...