Jump to content
Nokioteca Forum
Sign in to follow this  
Il.Socio

Hack Per Tutti I Modelli - Flash Del Firmware Con Phoenix (Aggiunta Di Rp+)

Recommended Posts

Con l'hard reset perderesti l'hack... quindi, non solo non e' preferibile, ma finirebbe per essere controproducente.

Puoi perdere l'hack anche andando a cancellare manualmente i file c:\sys\bin\*.ldd

Share this post


Link to post
Share on other sites

In quale cartella hai inserito i files del firmware che hai scaricato da NaviFirm+?

Qual'e' il path che ti compare quando segui il punto 1 della guida?

Il path in Phoenix è c:\documents and settings\all users\dati applicazioni\nokia\packages (o qualcosa di simile, non sono al mio PC ora e vado a memoria)

Comunque, ho navigato fino alla cartella nokia, mancava la packages che ho creato io ed al suo interno ho creato la sottocartella RM-588

Ho quindi copiato il mio UDA modificato e tutti gli altri dati scaricati con navifirm lì dentro, non va.

Siccome questo passaggio non è chiarissimo sulla guida, ho provato anche a rinominare la cartella RM-588 in RM588 e in RM588_50.0.001_000_000_U001, tanto per non cadere in qualche errore banale di interpretazione della guida, senza successo.

Ho provato cancellando tutto e scaricando direttamente con navifirm in quella cartella, e a modificare l'uda lì dentro, nulla

Infine, ho pure provato a scaricare direttamente dentro senza patchare l'uda, ancora non me lo vede

Come ultima risorsa, da una ricerca su google avevo trovato che per risolvere bisognava cambiare le Product Locations in Phoenix, ed ho prvato ad assegnare il percorso alla mia cartella anche da lì. Purtroppo è un errore su cui neanche BigG sembra sapere molto, almeno non finchè non faccio un corso di russo o di arabo... :( Nulla (anche se ho un dubbio in questo. Ho cambiato solo la USER, mentre la ADMINISTRATOR è rimasta quella di default... mumble, stasera ci provo...)

Intanto ringrazio per aver reso disponibile l'uda per il mio cell, immagino che altri apprezzeranno :) Stasera riprovo con calma e un po' meno sonno addosso e vediamo dove sto sbagliando (di sicuro è qualche cavolata che ho dimenticato, quanto mi seccano ste cose!!!! <_<

Edited by s_bastian

Share this post


Link to post
Share on other sites

Siccome questo passaggio non è chiarissimo sulla guida

Puoi riportare il testo esatto della guida del passaggio che non ti e' chiaro?

Cosi' vediamo di migliorarlo...

Share this post


Link to post
Share on other sites
2. Utilizzando NaviFirm+, scaricate i files del firmware originale che avete attualmente, accertandovi di scaricare quello corrispondente al vostro Product Code, ed alla vostra versione fw e salvateli nel percorso che avevate annotato (*) "c:\ProgramData\Nokia\Packages\RM-...\" creando la cartella "RM-..."

Nella parte in grassetto non è chiarissimo come deve essere fatta e nominata la cartella. Penso sarebbe di più facile comprensione

2. Utilizzando NaviFirm+, scaricate i files del firmware originale che avete attualmente, accertandovi di scaricare quello corrispondente al vostro Product Code, ed alla vostra versione fw. Create nella cartella precedentemente annotata (es: (*) "c:\ProgramData\Nokia\Packages\) una sottocartella nominata RM-xxx dove la XXX indicano il vostro numero di RM e salvateci all'interno i file che avete scaricato:

Esempio: "c:\ProgramData\Nokia\Packages\RM-588\"

Mi sembra che così sia più comprensibile, poi vedete voi come/se aggiustare la cosa ;)

Edited by s_bastian

Share this post


Link to post
Share on other sites

Voglio fare l hack al mio e52 aggiornato alla v71,solo che in navifirm non esiste ancora il product code italiano per questa versione firmware.

Cè una soluzione o sono costretto a fermarmi?

Datemi una risposta per favore,sono 2 giorni che ci sbatto la testa..

Share this post


Link to post
Share on other sites

Nada... altra ora persa a fare test vari ed eventual... sempre lo stesso errore... Può essere un problema di versione di Phoenix? Non ci sono altri modi (es JAF funziona uguale??)

Share this post


Link to post
Share on other sites

Nada... altra ora persa a fare test vari ed eventual... sempre lo stesso errore... Può essere un problema di versione di Phoenix? Non ci sono altri modi (es JAF funziona uguale??)

ti consiglio di guardare attentamente il video, pure io ero nella tua stessa situazione e ho seguito bene il video e si vede che mette la cartella RM- dentro la cartella phoenix/products.. se guardi bene il video ci riesci!

Edited by tidus_86

Share this post


Link to post
Share on other sites

Se così fosse vuol dire che la guida sbaglia a dirti di controllare il percorso del download (punti 1 e 2 della guida.. :unsure:

Faccio anche questa prova... :P

Share this post


Link to post
Share on other sites

Ebbene si, tidus ha ragione. Dopo aver fatto una mezza dozzina di spostamenti di cartelle e riavvii di Phoenix , sono giunto alla conclusione che sarebbe più corretto modificare la guida (previ vostri opportuno controlli e test, ovviamente... :) o integrarla con istruzioni alternative nel caso qualcuno abbia problemi

Per opportuno riscontro, questo è quel che vedo al punto 1 della vostra guida:

Percorso mostrato nel punto 1

Bisogna invece controllare nelle opzioni le impostazioni della Product Location:

Product Location

A quel punto, si controlla cosa è impostato come Data Package 1.0

Percorsi

Che almeno nel mio caso corrisponde alla cartella di installazione di Phoenix :)

Si crea al suo interno una cartella Packages e ci si piazza dentro la RM-, ed a questo punto VA

Da notare che una volta caricato con successo il product, Se rieseguo il cotnrollo del punto 1 mi da la mia location:

Product Download aggiornato

Spero che questo possa aiutare altri :)

Edited by s_bastian

Share this post


Link to post
Share on other sites

Tu hai eseguito passaggi che non avresti dovuto effettuare:

Come ultima risorsa, da una ricerca su google avevo trovato che per risolvere bisognava cambiare le Product Locations in Phoenix, ed ho prvato ad assegnare il percorso alla mia cartella anche da lì.

Quindi, le conclusioni a cui sei giunto, partono da una configurazione che non e' quella di default e che e' inconsistente con il resto della guida.

Per determinare se e' realmente necessario modificare la guida, dovresti disinstallare completamente Phoenix (sperando che vengano anche rimosse le relative impostazioni che hai effettuato).

Installare da zero la versione allegata a questa guida e seguire scrupolosamente i passaggi indicati...

Per opportuno riscontro, questo è quel che vedo al punto 1 della vostra guida:

Percorso mostrato nel punto 1

Quello e' il path corretto, quando Phoenix viene installato su XP...

Avresti dovuto annotarlo, cosi' come indicato nella guida, per poi andare a piazzare i file del fw in:

C:\Documents and Settings\All Users\Application Data\Nokia\Packages\RM-588\

Edited by Il.Socio

Share this post


Link to post
Share on other sites

mmmm no, e c'è scritto chiaramente nel mio post... PRIMA ho seguito la guida passo passo, POI ho provato le strade alternative.

Il path in Phoenix è c:\documents and settings\all users\dati applicazioni\nokia\packages (o qualcosa di simile' date=' non sono al mio PC ora e vado a memoria)

Comunque,[b'] ho navigato fino alla cartella nokia, mancava la packages che ho creato io ed al suo interno ho creato la sottocartella RM-588[/b]

Ho quindi copiato il mio UDA modificato e tutti gli altri dati scaricati con navifirm lì dentro, non va.

- il percorso del Download Product lo vedi nello screenshot qui sopra (il primo). La primissima cosa che ho fatto è stato creare la cartella RM- lì dentro, senza successo. All'avvio del programma è semrpe quello, indipendentemente da quelle che sono le product location. POI cambia invece quando viene caricato il product, il che mi fa pensare che Phoenix PRIMA cerca le product location e POI imposta la Download Location. Da qui il mio consiglio di modiicare la guida.

- Se cancelli TUTTI i percorsi dalle impostazioni del product location, Phoenix li ripristina automaticamente a quelli suoi di default, che sono quelli che vedi nel mio terzo screenshot (almeno, nella mia installazione). Questo dovrebbe rendere superfluo il disinstallare completamente phoenix (che con il videotelegrafo a pedali che mi trovo come PC è stata la parte più penosa della procedura... :( )

Comunque, Tidus ha ragione nel dire che nel video i files vengono messi nella cartella di Phoneix, sottocartella Packages. Manca però nel video la parte di identificazione edlla cartella (il famigerato punto uno) per cui in realtà portebbe essere una coincidenza, ma non mi sembra che Tidus abbia fatto tutti i miei esperimenti, e pure a lui è andata, e questo dovrebbe fare riflettere. Magari è sfiga nostra che per qualche motivo con XP ci litiga, ma sia io che lui abbiamo XPsp3 ed ad entrambi così è andata...

Vabbè, valutate voi che fare dei miei post, se fare qualche test anche voi o se limitarvi a lasciarli nella discussione a fare bibliografia. Io ho risolto e potevo sparire come fanno in giro, ma cercato di contraccambiare i consigli ricevuti con le mie esperienze, tutto qui ;)

Edited by s_bastian

Share this post


Link to post
Share on other sites

Comunque, Tidus ha ragione nel dire che nel video i files vengono messi nella cartella di Phoneix, sottocartella Packages. Manca però nel video la parte di identificazione edlla cartella (il famigerato punto uno) per cui in realtà portebbe essere una coincidenza, ma non mi sembra che Tidus abbia fatto tutti i miei esperimenti, e pure a lui è andata, e questo dovrebbe fare riflettere. Magari è sfiga nostra che per qualche motivo con XP ci litiga, ma sia io che lui abbiamo XPsp3 ed ad entrambi così è andata...

Voglio specificare una cosa, io avevo scritto che non riuscivo a installarlo su xp, siccome non volevo cancellare tutti i programmi nokia che avevo, ho usato un altro pc che avevo "pulito" senza programmi nokia e il sistema operativo era windows 7!

Share this post


Link to post
Share on other sites

Vabbè, valutate voi che fare dei miei post, se fare qualche test anche voi o se limitarvi a lasciarli nella discussione a fare bibliografia. Io ho risolto e potevo sparire come fanno in giro, ma cercato di contraccambiare i consigli ricevuti con le mie esperienze, tutto qui ;)

Appena riesco, verifico su XP SP3 e magari modifichiamo la guida per sistemare il tutto! :)

Edited by Il.Socio

Share this post


Link to post
Share on other sites

Io ho un dubbio, mettendo questi file in bin, poi installando rp siamo sicuri che vada? Perchè io ho un devcert richiesto dopo la data della modifica.

Share this post


Link to post
Share on other sites

Buona sera, ho qualche domanda per quanto riguarda questa procedura.

Ho scaricato con navifirm1.3+ l'ultima versione del firm per il mio e72, ho provveduto manualmente ad inserire i 3 files e ho salvato il file che ne è uscito.

Installando questa versione cucinata mi sarà possibile installare applicazioni non signate? Ho letto più da una parte che l'e72 non è hackerabile, quindi prima di applicare questa procedura vorrei dissipare questo dubbio.

Grazie in anticipo.

Share this post


Link to post
Share on other sites

Si, ti sara' possibile installare applicazioni non signate.

"Ho letto più da una parte che l'e72 non è hackerabile"

Quanto hai letto e' sbagliato (e non credo tu lo abbia letto qui su Nokioteca) perche' seguendo questa procedura lo potrai hackare tranquillamente. :)

E con la medesima procedura possono essere hackati anche tutti quanti gli altri modelli...

Edited by Il.Socio

Share this post


Link to post
Share on other sites

Ciao!

io vorrei capire, installando questa UDA hackata nel mio cel cos'ho fatto di preciso. SOno curiosa di capire il funzionamento :)

ti chiedo xkè pensavo ke in questa maniera hackavo il cel invece poi leggo ke devo cmq fare la richiesta del cert. Mi potresti togliere questa curiosità? :rolleyes:

Questa procedura l'ho eseguita su Nokia E5 quindi ho creato l'UDA "by my self" :)

Share this post


Link to post
Share on other sites

Se segui la guida, dovresti dedurre da sola cosa hai fatto di preciso:

- hai flashato un firmware modificato, che rispetto all'originale, contiene in piu' i files \sys\bin\*.ldd

Ne' piu' ne' meno di questo.

I files *.ldd se utilizzati in maniera opportuna, consentono di ottenere il libero accesso al sistema.

RP+ e' il programma che si occupa di utilizzarli in maniera opportuna.

Se ti fossi limitata a flashare il firmware originale, non avresti i files \sys\bin\*.ldd

E quindi non avresti potuto ottenere il libero accesso al sistema.

Edited by Il.Socio

Share this post


Link to post
Share on other sites

Ciao ho eseguito la procedura su E52 054.003 , con navifirm ho trovato tanti firmaware ma ho prese uno che mi sembrava vicino al mio tel (country variant italy navi metal) almeno la uda aveva lo stesso nome del file

che mi dava phoenix quando facevo lo scan.

ho inserito i 3 ldd nella UDA con nokiacooker e poi ho sovrascritto il file scaricato con navifirm.

Phoenix è partipo bene ma poi mi ha chiesto di togliere la batteria e il cavo usb (ma non ho dovuto premere power altrimenti non entrava in flash mode) al finalizing flash mi si è bloccato dicendo di verificare il corretto boot del terminale. in effetti si era riavviato con il nuovo firmware non è riuscito a fare il chech comminication.

ho fatto cancel e mi è sembrato che comunque l'aggiornamento è stato fatto, almeno a livello di grafica.

Poi ho segnato il rp+ lite con i devcert di nokioteca presi dopo il 24/06 ma quando provo ad installare mi dice certificato scaduto, se porto la data indietro mi dice impossibile.

Dovrei provare a reinstallare? sulla cartella di ncooker ho visto nella cartella SYS BIN i 3 file quindi credo sia a posto l'unico dubbio è sulla finalizzazione di phoenix, non sono sicuro che sia completamente installato.

Grazie.

Share this post


Link to post
Share on other sites

Cavoli, é una settimana che ci sto litigando!! :incazzato:

Mi pianto al punto 6 e quando clicco sui 3 puntini Phoenix mi ritorna il messaggio d'errore "Neither DP1.0 nor DP2.0 was found for the Product, or the Product cannot be identified."

Sono su Win7 64 e ho un Nokia C6-00 v20.0.042 e sto cercando di usare il cooked firmware lite della sezione "Pronti all'uso".

Premetto che anche seguendo quest'altra guida http://www.nokioteca.net/home/forum/index.php/topic/204060-come-flashare-il-firmware-usando-phoenix/ non riesco a proseguire, piantandomi sempre allo stesso punto ma con messaggio d'errore diverso (e molto più lungo!)..... :mumble:

FIn da ora...un sincero grazie per l'aiuto!! :thumbs:

Share this post


Link to post
Share on other sites

E72 - RM-530 - 071.004 hacked uda

http://www.mediafire.com/download.php?k203cnnxszjw7gu

Questa UDA non verra' aggiunta a questa lista perche' non e' stata hackata seguendo le istruzioni presenti in questa guida...

Ne e' stata aggiunta una simile per E72, che e' stata realizzata in maniera corretta, rispettando le istruzioni presenti nella guida.

Poi ho segnato il rp+ lite con i devcert di nokioteca presi dopo il 24/06 ma quando provo ad installare mi dice certificato scaduto

Imposta la data odierna sul cellulare e non dovresti avere nessun problema.

Mi pianto al punto 6 e quando clicco sui 3 puntini Phoenix mi ritorna il messaggio d'errore "Neither DP1.0 nor DP2.0 was found for the Product, or the Product cannot be identified."

Fossi in te, proverei a disinstallare Phoenix, scaricarlo da questo thread e seguire passo passo le istruzioni presenti in questa guida.

Edited by Il.Socio

Share this post


Link to post
Share on other sites

OTTIMO, E52 054.003 ok, dopo aver preparato il fw cooked con RP+ lite

sono riuscito a certificare il rp...sis con sisSigner.

adesso si installano gli unsigned.

Non vale la pena di inviare i fw è veramente facile il cooking!!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...