Jump to content
Nokioteca Forum

Ubuntu 10.10 E La Nvidia 8500 Gt


Magix11
 Share

Recommended Posts

Ciao a tutti!

Ho iniziato una nuova discussione perchè è da qualche settimana che ho virtualizzato Ubuntu 10.10 con VMWare Workstation Professional dato che mi serve per programmare in C e per altri motivi [ tipo hacking ecc.. (: ]..

Bene, allora, l'installazione è andata a buon fine, però io volevo anche gli effetti grafici di Compiz, e con grande dispiacere ricevo il messaggio impossibile attivare gli effetti grafici.... La causa sono i driver mancanti per questa distro di linux a quanto ho capito, però non ne sono sicuro... io ho provato ad installarli dall'Ubuntu Software Center, dove ho trovato i Binaries per le nuove schede video (almeno così diceva il pacchetto...) e li ho installati, ma nulla!

Sono andato sul sito della NVIDIA nella sezione download, ho provato quasi tutti i tipi di driver (da considerare che sono un 32 bit, quindi i 64 non funzionano) e nulla, non ho ancora concluso niente!

C'è nessuno che mi può aiutare?? vi preeeegoo!! ah, se ci riuscite, mi potreste scrivere passo-passo ciò che bisogna fare? (sono un nabbo di linux, però ricordate che c'è sempre una prima volta ;) )

Grazie in anticipo a tutti quelli che mi vorranno rispondereee!

Ciao ciao!

Magix11.

Link to comment
Share on other sites

Ciao a tutti!

Ho iniziato una nuova discussione perchè è da qualche settimana che ho virtualizzato Ubuntu 10.10 con VMWare Workstation Professional dato che mi serve per programmare in C e per altri motivi [ tipo hacking ecc.. (: ]..

Bene, allora, l'installazione è andata a buon fine, però io volevo anche gli effetti grafici di Compiz, e con grande dispiacere ricevo il messaggio impossibile attivare gli effetti grafici.... La causa sono i driver mancanti per questa distro di linux a quanto ho capito, però non ne sono sicuro... io ho provato ad installarli dall'Ubuntu Software Center, dove ho trovato i Binaries per le nuove schede video (almeno così diceva il pacchetto...) e li ho installati, ma nulla!

Sono andato sul sito della NVIDIA nella sezione download, ho provato quasi tutti i tipi di driver (da considerare che sono un 32 bit, quindi i 64 non funzionano) e nulla, non ho ancora concluso niente!

C'è nessuno che mi può aiutare?? vi preeeegoo!! ah, se ci riuscite, mi potreste scrivere passo-passo ciò che bisogna fare? (sono un nabbo di linux, però ricordate che c'è sempre una prima volta ;) )

Grazie in anticipo a tutti quelli che mi vorranno rispondereee!

Ciao ciao!

Magix11.

da nvidia non puoi più scaricare i driver....fai tasto destro nella scrivania cambia sfondo, spostati nel tab effetti grafici o come si chiama (è l'ultimo tab) e seleziona aggiuntivi dovrebbe dirti che nonhai i driver e te li cerca e te li installa e poi dopo il riavvio dovrebbe funzionarti tutto...

prova sperò di essere stato abbastanza chiaro

Link to comment
Share on other sites

da nvidia non puoi più scaricare i driver....fai tasto destro nella scrivania cambia sfondo, spostati nel tab effetti grafici o come si chiama (è l'ultimo tab) e seleziona aggiuntivi dovrebbe dirti che nonhai i driver e te li cerca e te li installa e poi dopo il riavvio dovrebbe funzionarti tutto...

prova sperò di essere stato abbastanza chiaro

uao! che velocità a rispondere! :)

comunque ho già provato a fare come hai detto tu, ma dopo che è comparsa la finestra di ricerca dei driver (quella piccola finestra con la barra che scorre avanti e indietro e che recita Ricerca dei driver in corso...) la GUI è come se si riavviasse temporaneamente, però al termine di tutto ciò compare l'errore Impossibile attivare gli effetti grafici...

Hai altre soluzioni? te ne sarei mooolto grato! :)

grazie ancora della risposta!

Ciaociao

Magix11.

Link to comment
Share on other sites

uao! che velocità a rispondere! :)

comunque ho già provato a fare come hai detto tu, ma dopo che è comparsa la finestra di ricerca dei driver (quella piccola finestra con la barra che scorre avanti e indietro e che recita Ricerca dei driver in corso...) la GUI è come se si riavviasse temporaneamente, però al termine di tutto ciò compare l'errore Impossibile attivare gli effetti grafici...

Hai altre soluzioni? te ne sarei mooolto grato! :)

grazie ancora della risposta!

Ciaociao

Magix11.

prova con questo programma http://informaticlife.wordpress.com/2008/02/27/installare-driver-della-scheda-video-su-ubuntu-in-pochi-secondi-con-envy/

Link to comment
Share on other sites

an beh in macchina virtuale non funziona nemmeno con quel programma...non puoi

>.< ah davvero? -.-' oggi non è giornata!

ora non so nemmeno come fare a farlo partire, visto che ubuntu mi si blocca in fase di login

resta in console su tty1 e non fa partire X....

ora provo a rebootare... MALEDETTO LINUX!!!!!! :@

e pensare che andava così beneee!!!!! ma cosa ho fatto di maleee :(:(:(:(

dove posso postare per cercare di risolvere un errore di linux? (qui sarebbe OT penso.... no?)

Link to comment
Share on other sites

>.< ah davvero? -.-' oggi non è giornata!

ora non so nemmeno come fare a farlo partire, visto che ubuntu mi si blocca in fase di login

resta in console su tty1 e non fa partire X....

ora provo a rebootare... MALEDETTO LINUX!!!!!! :@

e pensare che andava così beneee!!!!! ma cosa ho fatto di maleee :(:(:(:(

dove posso postare per cercare di risolvere un errore di linux? (qui sarebbe OT penso.... no?)

io non so niente o quasi di ubuntu\linux...chiedi nel forum di ubuntu

Link to comment
Share on other sites

io non so niente o quasi di ubuntu\linux...chiedi nel forum di ubuntu

ora cerco qualcosa in giro su google, vediamo che trovo...

penso che questa discussione possa essere chiusa no? tanto soluzioni non ce ne sono....

(p.s.: quasi quasi mi virtualizzo DOS che almeno non ho errori! -.-')

sempre detto che l'unico programma che non ha errori è helloworld!

grazie dell'aiuto iFraska!

ciaociao!

Magix11.

Link to comment
Share on other sites

Ciao...

fammi capire... hai virtualizzato Ubuntu da winzozz e pretendi che ti attivi gli effetti grafici aggiuntivi di compiz? :wacko:

la vedo parecchio in salita...

perchè non provi a fare il contrario (virtualizzare windows da ubuntu tramite VirtualBox) oppure a fare un semplice dual boot?

col dual boot vai liscio e sfrutti entrambi i sistemi al massimo delle possibilità che offre il tuo hardware...

virtualizzando da linux fai appoggiare la macchina virtuale ad un sistema di per sè già più leggero di windows (sicchè più risorse)

anche se ubuntu non è propio il massimo della leggerezza....

;)

Link to comment
Share on other sites

Ciao...

fammi capire... hai virtualizzato Ubuntu da winzozz e pretendi che ti attivi gli effetti grafici aggiuntivi di compiz? :wacko:

la vedo parecchio in salita...

perchè non provi a fare il contrario (virtualizzare windows da ubuntu tramite VirtualBox) oppure a fare un semplice dual boot?

col dual boot vai liscio e sfrutti entrambi i sistemi al massimo delle possibilità che offre il tuo hardware...

virtualizzando da linux fai appoggiare la macchina virtuale ad un sistema di per sè già più leggero di windows (sicchè più risorse)

anche se ubuntu non è propio il massimo della leggerezza....

;)

mah, guarda, io uso più Windows di ubuntu e quindi preferisco avere una macchina virtuale piuttosto che fare dual boot o robe del genere... cmq a questo punto lascio stare compiz e company e sfrutto solo la parte tecnica del sistema operativo, anche perchè il mio obiettivo principale era fare un po' di lamer-hacking :lmaosmiley: e mi sono lasciato prendere dalla mania degli effetti... ora addirittura non mi parte nemmeno più il sistema O.O da non credere.... mi da errori sui driver NVIDIA e qualcos'altro... se ti va di aiutarmi potrei scrivere l'errore che ricevo...

grazie ancora dei suggerimenti in ogni caso :)

troppo gentili voi di nokioteca! (:

Ciaociao,

Magix11!

Link to comment
Share on other sites

se ti va di aiutarmi potrei scrivere l'errore che ricevo...

se non altro ci posso provare.... ;)

ti dico subito che ho più esperienza con SUN VirtualBox che con WMware comunque...

http://www.virtualbox.org/wiki/Downloads

leggo che stai dando una sbirciata all'hacking e allo sniffing dei dati...

Ubuntu non è propio indicata per lo scopo. O meglio... potrebbe diventarlo ma aggiungendo diversi pacchetti che non troveresti di default...

forse dovresti dare un'occhiata a backtrack 4...

http://www.backtrack-linux.org/

magari sempre in virtual machine...

hai visto mai che ti appassioni davvero e fai un'istallazione pulita... :D

;)

Link to comment
Share on other sites

se non altro ci posso provare.... ;)

ti dico subito che ho più esperienza con SUN VirtualBox che con WMware comunque...

http://www.virtualbo.../wiki/Downloads

leggo che stai dando una sbirciata all'hacking e allo sniffing dei dati...

Ubuntu non è propio indicata per lo scopo. O meglio... potrebbe diventarlo ma aggiungendo diversi pacchetti che non troveresti di default...

forse dovresti dare un'occhiata a backtrack 4...

http://www.backtrack-linux.org/

magari sempre in virtual machine...

hai visto mai che ti appassioni davvero e fai un'istallazione pulita... :D

;)

mmh ora do un'occhiata a questo "backtrack-linux" e ti faccio sapere! grazie ancora per i consigli a tutti! :)

ora purtroppo non ho il tempo materiale di postare l'errore, però ci posso provare un giorno di questi!

grazie ancora!

Ciaociao,

Magix11!

Link to comment
Share on other sites

ora purtroppo non ho il tempo materiale di postare l'errore, però ci posso provare un giorno di questi!

grazie ancora!

Ciaociao,

Magix11!

nulla di strano che a furia di tentativi tu sia andato ad incasinare xorg (in genere la cosa è risolvibile da modalità provvisoria oppure aprendo un terminale in avvio dando startx , in pratica forzando l'avvio dell'interfaccia grafica)...

se poi non ti avvia del tutto possibile che il problema sia di grub...

oppure (ancora peggio) che sia andato a mettere le manine in qualche file di sistema non meglio definito...

le cose sono due:

1) andare a cercare l'errore (posso capire con una istallazione a cui tieni particolarmente)

2) reistallare da capo

andrei sulla seconda....;)

Link to comment
Share on other sites

nulla di strano che a furia di tentativi tu sia andato ad incasinare xorg (in genere la cosa è risolvibile da modalità provvisoria oppure aprendo un terminale in avvio dando startx , in pratica forzando l'avvio dell'interfaccia grafica)...

se poi non ti avvia del tutto possibile che il problema sia di grub...

oppure (ancora peggio) che sia andato a mettere le manine in qualche file di sistema non meglio definito...

le cose sono due:

1) andare a cercare l'errore (posso capire con una istallazione a cui tieni particolarmente)

2) reistallare da capo

andrei sulla seconda....;)

hehe... in effetti la seconda è quella che ho pensato da subito... purtroppo ho provare a installare i driver NVIDIA dall'ubuntu software center, e finchè non ho riavviato andava tutto bene... appena riavviato: ciaociao linux...!

comunque la mia testardaggine mi porterebbe a cercare l'errore, ma siccome non ho tempo materiale per farlo, ho considerato la seconda principalmente...

quindi ora mi guardo un po' questa distro di linux "backtrack" che sembra fare al caso mio...

bobboh... non so, ora vedo che fare...

in ogni caso ora provo ad eseguire il comando startx e vedere che succede... io ho provato con gdm restart e con X ma non succede nulla, forse sbaglio io a dare i comandi.... boh...

sono nabbo di linux, e sto imparando, anche se uso windows da quando ho 4 anni e quindi diciamo che con i pc ci mastico abbastanza... dos lo conosco meglio delle mie tasche e vedo che non c'è poi così tanta differenza nei comandi base di bash, quindi...

ora provo e ti faccio sapere...!

Ciaociao,

Magix11.

Link to comment
Share on other sites

@luka@70

appena provato a fare startx e mi dice questo: (salto le righe in cui viene detto che S.O. ho ecc okey?)

FATAL: Module NVIDIA not found

(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your

(EE) NVIDIA: system's kernel log for additional error messages.

(EE) Failed to load module "nvidia" (module-specific error, 0)

(EE) No drivers available

Fatal server error:

no screens found

Link to comment
Share on other sites

nelle istallazioni in VMachine la macchina ospite si appoggia sui driver della macchina ospitante...

hai mai provato ad istallare una distribuzione windows in una macchina percui non è nativa?

se la istalli da CD devi cercare driver per tutto (a iniziare da quelli dell'hard disk, se la istalli in VMachine funziona tutto!

secondo me, provando a reistallare i driver video dall'interno di ubuntu, questi vengono cercati dove non possono essere trovati...

così a occhiometro gli hai incasinato xorg.conf

;)

Link to comment
Share on other sites

Mi sembra logico che si lamenti che non trova una scheda video nvidia, la macchina virtuale ha il suo hardware virtuale...

Per sistemare prova a lanciare da console:

sudo apt-get purge nvidia-current

Se non funziona sostituisci a "nvidia-current" il nome del pacchetto che hai installato.

Se non te lo ricordi esegui:

sudo aptitude

e cercatelo, se non sai usare aptitude c'è il man:

man aptitude

Con vmware non puoi abilitare compiz, nemmeno installando le vmware tools. Devi usare virtualbox e installare su ubuntu le virtualbox additions.

Fossi in te mi risparmierei tutti sti problemi e installerei ubuntu con Wubi.

Link to comment
Share on other sites

Mi sembra logico che si lamenti che non trova una scheda video nvidia, la macchina virtuale ha il suo hardware virtuale...

Per sistemare prova a lanciare da console:

sudo apt-get purge nvidia-current

Se non funziona sostituisci a "nvidia-current" il nome del pacchetto che hai installato.

Se non te lo ricordi esegui:

sudo aptitude

e cercatelo, se non sai usare aptitude c'è il man:

man aptitude

e come la apre la console (kubuntu?) o il terminale se non riesce ad avviare il sistema?

sinceramente non sono sicuro se con alt+F1 in avvio riuscirebbe...

comunque:

sudo apt-get --purge nome_pacchetto

sennò nisba!

Con vmware non puoi abilitare compiz, nemmeno installando le vmware tools. Devi usare virtualbox e installare su ubuntu le virtualbox additions.

non so se riuscirebbe nemmeno così (abilitando l'accelerazione 3D e istallando da ubuntu le VBox additions)... troppe risorse e sta agendo da windows...

vediamo il lato positivo:

almeno anzichè VMWare prova VirtualBox! ;)

Fossi in te mi risparmierei tutti sti problemi e installerei ubuntu con Wubi.

e sarebbe punto e a capo...

wubi istalla ubuntu su partizione virtuale ma agisce come un vero e propio dual boot... va bene per i GNUbbi che vogliono provare ubuntu senza ridurre la partizione winzozz e rischiare casini.

lui vuole aprire una sessione linux all'interno di una sessione windows...

a quel punto tanto varrebbe istallare pulito su partizione fisica! :P

Link to comment
Share on other sites

e come la apre la console (kubuntu?) o il terminale se non riesce ad avviare il sistema?

sinceramente non sono sicuro se con alt+F1 in avvio riuscirebbe...

comunque:

sudo apt-get --purge nome_pacchetto

sennò nisba!

non so se riuscirebbe nemmeno così (abilitando l'accelerazione 3D e istallando da ubuntu le VBox additions)... troppe risorse e sta agendo da windows...

vediamo il lato positivo:

almeno anzichè VMWare prova VirtualBox! ;)

e sarebbe punto e a capo...

wubi istalla ubuntu su partizione virtuale ma agisce come un vero e propio dual boot... va bene per i GNUbbi che vogliono provare ubuntu senza ridurre la partizione winzozz e rischiare casini.

lui vuole aprire una sessione linux all'interno di una sessione windows...

a quel punto tanto varrebbe istallare pulito su partizione fisica! :P

scusate se rispondo in ritardo... grazie ancora delle informazioni!

comunque se volete io riesco ad entrare in recovery mode come root e in ogni caso non avrei nemmeno problemi a cambiare tty con la sequenza ctrl+alt+numero

ora provo a fare tutto quello che mi avete suggerito da console in recovery come root e vediamo che succede, intanto scarico backtrack, che mi sembra millemila volte meglio per i miei scopi XD

se vi dovesse servire come info: io ho installato i driver aggiuntivi di VMWare, quel pacchetto driver che ti fa fare cose che normalmente non si possono fare senza quelli (i VMWare Tools penso si chiamino...) e ho soltanto provato ad installare i driver di NVIDIA perchè volevo vedere se funzionava compiz... ma a quanto pare ho fatto la cavolata....! come al solito, io e la mia curiosità... -.-'

in ogni caso, se io rimuovessi Xorg.conf succederebbe qualcosa di anomalo oppure farei qualcosa di buono?

fatemi sapere!

grazie ancora della disponibilità!

Nokioteca ---> i migliori!!

Ciaociao,

Magix11!

Link to comment
Share on other sites

Rimuovere e basta xorg.conf direi di no.... (in ogni caso quando dai operazioni rischiose fai sempre un backup dei file in questione)

Visto che il grande casino è successo istallando i driver da

amministrazione/hardware/driver

Potresti provare a disistallare esattamente da lì, riavvii e vedi come va...

Se vedi che non risolvi puoi provare come ti è stato suggerito da bolla da terminale (il commento --purge) serve a rimuovere oltre al pacchetto le relative impostazioni...

A livello generale comunque per procedure etc... È sempre meglio che ti basi sulle wiki ufficiali...

;)

Per il resto... Eh già... Backtrack spacca! :P

Link to comment
Share on other sites

e come la apre la console (kubuntu?) o il terminale se non riesce ad avviare il sistema?

sinceramente non sono sicuro se con alt+F1 in avvio riuscirebbe...

comunque:

sudo apt-get --purge nome_pacchetto

sennò nisba!

Giusto, --purge, ho dimenticato il --.

non so se riuscirebbe nemmeno così (abilitando l'accelerazione 3D e istallando da ubuntu le VBox additions)... troppe risorse e sta agendo da windows...

vediamo il lato positivo:

almeno anzichè VMWare prova VirtualBox! ;)

Con VirtualBox funziona, assicurato.

e sarebbe punto e a capo...

wubi istalla ubuntu su partizione virtuale ma agisce come un vero e propio dual boot... va bene per i GNUbbi che vogliono provare ubuntu senza ridurre la partizione winzozz e rischiare casini.

lui vuole aprire una sessione linux all'interno di una sessione windows...

a quel punto tanto varrebbe istallare pulito su partizione fisica! :P

Beh, fa sicuramente prima che con le macchine virtuali e non corre rischi modificando la partizione.

in ogni caso, se io rimuovessi Xorg.conf succederebbe qualcosa di anomalo oppure farei qualcosa di buono?

Prova a rinominarlo, oppure a modificarlo con vim e a sostituire "vesa" a "nvidia" qui:

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"

N.B. Potrebbe non essere esattamente così, io ho installato i driver a mano...

Link to comment
Share on other sites

Rimuovere e basta xorg.conf direi di no.... (in ogni caso quando dai operazioni rischiose fai sempre un backup dei file in questione)

Visto che il grande casino è successo istallando i driver da

amministrazione/hardware/driver

Potresti provare a disistallare esattamente da lì, riavvii e vedi come va...

Se vedi che non risolvi puoi provare come ti è stato suggerito da bolla da terminale (il commento --purge) serve a rimuovere oltre al pacchetto le relative impostazioni...

A livello generale comunque per procedure etc... È sempre meglio che ti basi sulle wiki ufficiali...

;)

Per il resto... Eh già... Backtrack spacca! :P

eccomi, scusate la lentezza ma gli impegni oggi hanno preso il soppravvento...

comunque vmware ha cominciato ad andare in crash per non so quale strano trucco di magia nera, e mi sono rotto le scatole di fare casino per ripristinare un sistema operativo di cui non vale la pena...

così ho seguito il consiglio di installarmi BackTrack e devo dire che sono rimasto veramente colpito da come sia fatto bene questo sistema!

mi meraviglio di linux!! (e io che ero così diffidenteee!!!)

comunque avevo provato tutti i comandi possibili di questa mondo ma niente, nichts, nada de nada! non si riusciva! così ho formattato e installato BT che è molto più al caso mio! :)

Grazie ancora di tutti i millemila consigli che mi avete dato! Siete sempre i migliori!

Grazie ancora,

ciaociao,

Magix11!!!! :P

Link to comment
Share on other sites

comunque vmware ha cominciato ad andare in crash per non so quale strano trucco di magia nera, e mi sono rotto le scatole di fare casino per ripristinare un sistema operativo di cui non vale la pena...

più che VMWare prova a dare un'occhiata a VirtualBox...

leggero, performante e open source! ;)

così ho seguito il consiglio di installarmi BackTrack e devo dire che sono rimasto veramente colpito da come sia fatto bene questo sistema!

per quello che hai intenzione di fare tu(test di sicurezza...politically correct uh? :P) è perfetto...

ma fammi capire...

l'hai istallato su partizione o in virtual machine?

ci sono exploit che richiedono potenza di calcolo (ad esempio i bruteforce)...

avendo a disposizione una scheda grafica NVidia puoi devolvere parte del processore grafico per aumentare la potenza di calcolo (cerca in rete "metodo cuda backtrack")

ad ogni modo BackTrack (dalla 4, la 3 si basava su SlackWare) si basa su ubuntu 8.10...

il che è ottimo per l'ampio supporto e l'ampiezza dei repository (la cosa, in linea di massima, ti evita di andare a compilare sorgenti)

mi meraviglio di linux!! (e io che ero così diffidenteee!!!)

eh... c'è tutto un mondo che segue Linux!

e, volente o nolente, ogni utente Linux è stato o è tuttora (suo malgrado!) utente windowzzz...

io ad esempio uso SOLO Linux (mi sono fermato su ubuntu) da 3 annetti...

non è che siamo tutti masochisti! :P

Edited by luk@70
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Questo sito utilizza i cookie per analisi, contenuti personalizzati e pubblicità. Continuando la navigazione, accetti l'utilizzo dei cookie da parte nostra | Privacy Policy