Jump to content
Nokioteca Forum

Tv In Streaming Su N900


Recommended Posts

ho risolto il problema dei permessi dello script, non me li cambiava perchè lo script l'avevo messo in /home/user/MyDocs/ che è la memoria formattata in fat32

ora l'ho spostato in /home/user/ e funziona bene.

Se a qualcuno interessa lo allego, in pratica lanciato lo script basta inserire il nome del canale che si vuole vedere e in automatico parte lo streaming!

Link to post
Share on other sites
  • Replies 98
  • Created
  • Last Reply

Top Posters In This Topic

ho risolto il problema dei permessi dello script, non me li cambiava perchè lo script l'avevo messo in /home/user/MyDocs/ che è la memoria formattata in fat32

ora l'ho spostato in /home/user/ e funziona bene.

Se a qualcuno interessa lo allego, in pratica lanciato lo script basta inserire il nome del canale che si vuole vedere e in automatico parte lo streaming!

allega allega :thumbs: ps. mi raccomando, spiega bene a prova di niubbo :thumbs:

Link to post
Share on other sites

come prima cosa dovete aver installato mplayer, poi:

Estraete il file allegato(mzp_tv.sh) e salvatelo nella cartella MyDocs (che sarebbe la cartella principale, quella che vi appare appena collegate il dispositivo come memoria di massa)

aprite xterminal e date i seguenti comandi:

sudo gainroot
cd MyDocs
mv mzp_tv.sh /home/user/mzp_tv.sh
cd ..
chmod +x mzp_tv.sh

Ora per vedere la tv basta digitare

./mzp_tv.sh

e scrivere il canale desiderato

screenshot2010010621311.png

mentre si guarda la tv:

col tasto P si và in pausa

col tasto F si passa dalla modalità full sceen alla modalità finestra

coi tasti E W si ingandisce/rimpicciolisce l'immagine

mzp_tv.zip

Edited by MaZZoPaZZo
Link to post
Share on other sites
dunque se non ho capito male quando arrivo a questa schermata se voglio vedere rai 1 basta che scrivo 1 e invio?

perchè se faccio così mi dice che mplayer ha crashato :) ( provato + volte)

Si devi premere 1, tu hai provato anche altri canali?

se lanci tu direttamaente mplayer da x terminal (mplayer -cache 3000 -user-agent "GNU/Linux" -playlist http://mediapolis.rai.it/relinker/relinker...et.htm?cont=983 )ti funziona?

A mè crashava dopo aver modificato il file di configurazione, tu magari l'hai modificato?

Link to post
Share on other sites
Np, non ho modificato il file di configurazione, per premura l'ho anche riscaricato, ma niente da fare, mi dice sempre quelle cose.

da terminale lanciando direttamente una volta mi ha funzionato rai1. Cavolo ma non funziona il copia-incolla in xterminal?

per incolare le cose in xterminal devi tappare in alto sulla scritta "xterminal" e da li scegliere incolla

Hai provato a riavviare il telefono oppure a disinstallare e reinstallare mplayer?

Cmq a mè funziona solo che a volte appena faccio partire un canale và per qualche secondo e poi si blocca e non riparte più

Link to post
Share on other sites

Mazzo, comunque a me funziona il file di configurazione!

Peccato che anche se ora è incluso in mplayer, KVMplayer sembra non andare ugualmente, forse devo riavviare poi provo!

In /etc/mplayer dovete creare il file mplayer.conf e inserire all'interno nella prima linea il seguente parametro:

user-agent="Linux"

L'unico problema è sempre che partono i video ma dopo un po si bloccano, ora non so questo da cosa può dipendere!!!

Edited by Burninghawk
Link to post
Share on other sites
Si esatto! Non sarà ancora ottimizzato bene per lo streaming!

Speriamo si sbrighino a terminare VLC per questo benedetto Maemo!

:thumbdown:

ogni tanto và ogni tanto non và :( speriamo nel vlc!

P.s.mi son dimeticato di dirti che ieri ho aggiornato il primo post e mi sono permesso di inserire i link della rai che hai postato tu, ovviamente ti ho citato!

Edit:

Ho trovato il problema, è l'audio!!!

con -nosound funzionano tutti perfettamente, ma ovviamente senza audio, ora smanetto un pò con le impostazioni dell'audio!

Edit2:

con "-ao pulse" mi funzionano perfettamente tutti i canali rai e mediset!!!!

provate anche voi e ditemi se abbiamo trovato la soluzione!

Edited by MaZZoPaZZo
Link to post
Share on other sites

io se si bloccano metto un'attimo in pausa e poi faccio ripartire e vanno fluidi...

invece volevo chiedere se esistevano ad una definizione un pò più bassa perchè così è impossibile guardarli in 3g

grazie a mazzopazzo per il lavoro che stà portando avanti

Link to post
Share on other sites
io se si bloccano metto un'attimo in pausa e poi faccio ripartire e vanno fluidi...

invece volevo chiedere se esistevano ad una definizione un pò più bassa perchè così è impossibile guardarli in 3g

grazie a mazzopazzo per il lavoro che stà portando avanti

Puoi provare ad aumentare il valore di "-cache" io ho messo 3000 che sono 3mb prova a raddoppiarli e vedi se migliora

Link to post
Share on other sites
Puoi provare ad aumentare il valore di "-cache" io ho messo 3000 che sono 3mb prova a raddoppiarli e vedi se migliora

cioe' raddoppiando il valore a 6000 si "consuma" la metà? quindi se metto 9000 consumerebbe 750 kb?

cmq ho messo già 6000 e, come a detto nyda83 che ringrazio, mettendo un attimo in pausa poi riparte fulido ;)

Link to post
Share on other sites

no, mettendo 6000 hai un buffer di 6mb, praticamente prima di partire accumula 6mb di dati che usa nel momento in cui la connessione rallenta.

Ti faccio un esempio, ipotiziamo che un secondo di streaming "consumi" 500kb con un buffer di 6mb puoi vedere 12 secondi di streaming anche senza connessione.

Link to post
Share on other sites
no, mettendo 6000 hai un buffer di 6mb, praticamente prima di partire accumula 6mb di dati che usa nel momento in cui la connessione rallenta.

Ti faccio un esempio, ipotiziamo che un secondo di streaming "consumi" 500kb con un buffer di 6mb puoi vedere 12 secondi di streaming anche senza connessione.

ah ok, perfetto, ora è chiaro. :mumble: ultima ( seeeee ;) ) cosa: il "consumo" è possibile gestirlo? magari perdendo qualcosina in qualità ( che cmq è ottima attualmente) a favore di un risparmio a livello di traffico dati quando non ci si puo' connettere con wifi.

PS: inutile dire che 6 un grande!

Link to post
Share on other sites

Per completezza sempre riepilogo il file di configurazione di mplayer come deve essere composto per utilizzare le opzioni

Il file mplayer.conf va creato dentro:

/etc/mplayer

e i parametri da inserire all'interno sono i seguenti:

user-agent="Linux"

ao=pulse

Spero sia tutto chiaro ora!

Grazie alla collaborazione di Escopazzo!

Buona visione a tutti!

;)

Link to post
Share on other sites
Per completezza sempre riepilogo il file di configurazione di mplayer come deve essere composto per utilizzare le opzioni

Il file mplayer.conf va creato dentro:

/etc/mplayer

e i parametri da inserire all'interno sono i seguenti:

user-agent="Linux"

ao=pulse

Senza cache non ti scattona mai?

Grazie alla collaborazione di Escopazzo!

;)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Questo sito utilizza i cookie per analisi, contenuti personalizzati e pubblicità. Continuando la navigazione, accetti l'utilizzo dei cookie da parte nostra | Privacy Policy